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Installation & Configuration Instructions 

 
 

----- REQUIREMENTS ----- 

 Windows NT, 2000, XP or 2003 that can be left running to initiate statistics collection  

 Permission to create and run Windows Scheduled Tasks  

 Remote or local AR System server version 6.0 or higher  

 All OS/DB combinations of the AR System Server that are supported by Remedy will 
work with the LicenseTracker  

 

----- PRODUCT SUPPORT ----- 

LicenseTracker - Build 070910 

Copyright © 2007 Waveform Enterprises Incorporated. All rights reserved. 

If you encounter any problems using this software, please do not hesitate to contact our 
support team via e-mail support@wave-form.com so that we may help you. 

Comments, suggestions, and enhancement requests are always welcome. Please send them 
to feedback@wave-form.com 

 

----- DEFINITIONS ----- 

Source – the AR System server you wish to monitor for license usage 

Target – the AR System server where the license statistics are stored 

 Note: If you wish to store the statistics on the same server that is being  
monitored, the Target and the Source will be the same. 
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----- SINGLE SERVER INSTALLATION INSTRUCTIONS ----- 

 Sections A through F of this document will describe how to install the 
LicenseTracker and configure a single Windows Workstation/Server to initiate 
statistics collection for a single AR System server. 

 

 Note: See Page 9 - Multiple Server Configuration once you have completed 
Sections A through F for instructions on how to initiate statistics collection for 
multiple AR System servers. 

 

A. Installing the LicenseTracker Files: 
 

1. Open the document LicenseTracker Installation and Configuration Instructions as 
a reference while installing this software. 

 

2. Make sure that all installation files are moved to the Windows Workstation/Server to 
be used to initiate statistics collection  (ex. C:\ drive). 

 

Option A From WinZip (or other archive program), choose the appropriate directory to 
unzip files. 

 If using WinZip Wizard > Select Different Folder > C:\ > OK. 

 If using WinZip Classic, use the Extract feature and select C:\ drive > OK. 
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Option B If your archive program places the files in a default directory, move the 
LicenseTracker folder from the default directory into the C:\ drive. 

 

 Go to Start > right-click, Explore > C:\ > right-click, Move Here  

 Then open the LicenseTracker folder to confirm that you have all 18 files before 
proceeding to next step. 

   

 

B. Importing the AR Definition Files to the Target Server (.def): 
 

3. Log into the Remedy Administrator Tool. 

 

4. Click on the Target Server (ex. vmremedy) > Tools > Import Definitions > From 
Definition File > C:\LicenseTracker > .def file > Open. 
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5. Choose Add All > Import; then click OK and Close the Import Definitions window.  

 

C. Editing your Source & Target Server Information (.cgf): 
 
6. Go to C:\LicenseTracker > License.cgf > right-click, Open With… > WordPad. 

 

7. In WordPad, edit the License.cfg file to specify the following, then save and close: 

 License Key: <Generated from your Source Remedy Server ID> 

 From Server: <Source server you wish to monitor for license usage> 

 From TCP Port: <TCP Port defined for Source server> 

 From UserName: <Remedy account with administrator privileges> 

 From Password: <Password> 

 To Server: <Target server where you wish to store the license statistics> 

 To TCP Port: <TCP Port defined for Target server> 

 To UserName: <Remedy account with administrator privileges> 

 To Password: <Password> 
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Unedited Configuration File vs. Edited Configuration File 

  

 Ensure that there are no trailing spaces behind the data entered into this file and 
that there is a hard return at the end of the configuration file. 

 

D. Confirming the Connection to the AR System Server(s) 
 

8. Next, run the executable FirstRegUserStats.exe to populate a list of all registered user 
accounts in the WAVE-UserStats form. 

 

 Go to C:\LicenseTracker > double-click, FirstRegUserStats.exe. 

 

9. If successful, the Command Prompt will appear and display the following verification 
message: 
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E. Troubleshooting Installation Errors 
 

 Cannot establish a network connection to the AR System server 

 Ensure that you have do not have any trailing spaces after the Server names 
in the License.cfg file. 

 Ensure that the TCP Ports in the License.cfg file match your server settings 
in the Remedy Administrator Tool under:  File > Server Information > 
Server Ports and Queues > Server TCP/IP Port. 

 Note: If you are using the 7.1.00 Remedy Administrator Tool, this information is 
now located in the: 

 Remedy User Tool > Object List > AR System Administration Console > 
System > General > Server Information > Ports and Queues > Server TCP/IP 
Port 

---------------------------------------------------- 

 Authentication failed 

 Ensure that you have do not have any trailing spaces after the User 
Names/User Passwords and that there is a hard return at the end of the 
License.cfg file. 

 
 

F. Configuring Windows Scheduled Tasks  
 

10. In order to automatically capture statistics, you will need to configure Scheduled Tasks 
to invoke: 

 UpdateCurUserStats.exe - Captures statistics on users currently logged 

 UpdateLicenseStats.exe - Captures summary statistics on licenses 
purchased, registered, and utilized 

 UpdateRegUserStats.exe - Captures statistics on registered users 

 

Option A Copying and Enabling Pre-Configured Windows Scheduled Tasks 

1. Open C:\LicenseTracker folder (keep 
open). 

2. Then, go to Start > Control Panel > 
Scheduled Tasks. 

3. Copy the following files from the 
C:\LicenseTracker folder to the   
Scheduled Tasks folder. 

 

 UpdateCurUserTask.job 

 UpdateLicenseTask.job 

 UpdateRegUserTask.job  
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4. Then for each Scheduled Task > right-click, Properties. 
 

 UpdateCurUserTask.job 

 UpdateLicenseTask.job 

 UpdateRegUserTask.job 

 

 

 

   

 

 

5. Make sure that the Enabled (scheduled task runs at specified time) box is checked. 

6. In the ‘Run as:’ field, make sure that the COMPUTER NAME\User Name is correct; 
then Set Password (User Password for computer). 

7. Type your password > confirm password > OK; then Apply > OK.  

8. Now run each task: right-click, Run; you should see status of the task show 
“Running”; the “Last Run Time” will then show the current date and time. 

   

9. To verify that the UpdateCurUserTask.job has run successfully:  

 Open the Remedy User Tool > Object List > WAVE-UserStats > Search.  

 Enter “%” in the ‘User Name’ and initiate your search.  

 Sort descending by ‘Last Update’.  The date/time should be within a few 
minutes of manually running the scheduled task. 

10. To verify that the UpdateLicenseTask.job has run successfully: 

 Go back to the Object List > WAVE-LicenseStats > Search.  

 Enter “%” in the ‘User Name’ and initiate your search.  

 Sort descending by ‘Last Update’.  The date/time should be within a few 
minutes of manually running the scheduled task.  
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Option B Manual method - Creating, Configuring & Enabling Windows Scheduled Tasks:  
 

a. Go to the Scheduled Tasks folder > Add Scheduled Task; the Scheduled Task 
Wizard will appear.  

b. Click, Next to continue; and then click Browse to find the executables located in 
the C:\LicenseTracker folder. Follow the same procedure for the three 
scheduled tasks listed below. 

---------------------------------------------------- 

c. For the first task - Browse to: C:\LicenseTracker\UpdateCurUserStats.exe 

d. Schedule the task to run Daily starting at 18 minutes after the hour (i.e. 8:18 
AM) > OK/NEXT. 

e. Enter COMPUTER NAME\User Name > Set Password (User Password for 
computer) > OK/NEXT. 

f. Confirm scheduled task and select the checkbox: Open Advanced Properties for 
this Task When I Click Finish > Finish.  

g. On the Schedule tab, click on the Advanced button and repeat the task every 
20 minutes > Set the Duration to 24 hours. 

---------------------------------------------------- 

h. For the second task - Browse to: C:\LicenseTracker\UpdateLicenseStats.exe 

i. Schedule the task to run Daily starting at the top of the hour (i.e. 8:00 AM) > 
OK/NEXT. 

j. Enter COMPUTER NAME\User Name > Set Password (User Password for 
computer) > OK/NEXT. 

k. Confirm scheduled task and select the checkbox: Open Advanced Properties for 
this Task When I Click Finish > Finish.  

l. On the Schedule tab, click on the Advanced button and repeat the task every 
12 minutes > Set the Duration to 24 hours. 

---------------------------------------------------- 

m. For the third task - Browse to: C:\LicenseTracker\UpdateRegUserStats.exe 

n. Schedule the task to run Daily starting at 12:01 AM) > OK/NEXT. 

o. Enter COMPUTER NAME\User Name > Set Password (User Password for 
computer) > Finish. 

 
 
 
 

----- SINGLE SERVER INSTALLATION COMPLETED ----- 
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----- MULTIPLE SERVER CONFIGURATION (OPTIONAL) ----- 

This section describes how to initiate statistics collection for multiple AR System servers.  
These instructions are based on the assumption that you have successfully completed 
Sections A through F.  

Option A Configure one Windows Workstation/Server for each AR System server. 

 

1. Repeat Sections A through F for each additional AR System server as needed.  

---------------------------------------------------- 

Option B Consolidate statistics collection for all AR System servers onto a single 
Windows Workstation/Server. Follow steps 1 through 10 on the following 
pages to complete installation. 
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1. Go to Start > right-click, Explore; right-click, Rename the LicenseTracker folder 
from C:\LicenseTracker to C:\LicenseTracker1. 

 

2. Right-click, Copy the entire C:\LicenseTracker1 folder and its contents > Paste 
back to the C:\ drive; then right-click, Rename the folder to C:\LicenseTracker2. 

 

3. Using the Remedy Administrator Tool, import the AR Definition file to the 
second Target Server: 

a. Click on the second Target Server > Tools > Import Definitions > From 
Definition File > C:\LicenseTracker2 > .def file > Open. 

b. Choose Add All > Import; then click OK; Close the Import Definitions 
window. 

 

4. Go to Start > Control Panel > Scheduled Tasks, right-click; Rename the existing 
Scheduled Tasks: 

 UpdateCurUserTask.job > UpdateCurUserTask1.job 

 UpdateLicenseTask.job > UpdateLicenseTask1.job 

 UpdateRegUserTask.job > UpdateRegUserTask1.job 
 

5. Re-point the three Scheduled Tasks by changing the properties for each task.  

a. Right-click, UpdateCurUserTask.job > Properties. 

b. Change the ‘Run:’ property “C:\LicenseTracker1\UpdateCurUserStats.exe”. 

c. Change the ‘Start in:’ property “C:\LicenseTracker1”. 

d. Click Apply > another window will appear, you must retype your Password 
(User Password for computer) > OK > OK again. 
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6. Return to the C:\LicenseTracker2 folder; right-click, Rename the existing 
Scheduled Tasks: 

 UpdateCurUserTask.job > UpdateCurUserTask2.job 

 UpdateLicenseTask.job > UpdateLicenseTask2.job 

 UpdateRegUserTask.job > UpdateRegUserTask2.job 
 

7. Next, Copy the Scheduled Task files from the C:\LicenseTracker2 folder to the 
Scheduled Tasks folder. 

 

8. Re-point the three Scheduled Tasks by changing the properties for each task. For 
example: 

a. Right-click on the UpdateCurUserTask; then choose Properties. 

b. Change the ‘Run:’ property “C:\LicenseTracker2\UpdateCurUserStats.exe”. 

c. Change the ‘Start in:’ property “C:\LicenseTracker2”. 

d. Click Apply > another window will appear, you must retype your Password 
(User Password for computer) > OK > OK again.  

---------------------------------------------------- 

9. Change the License.cfg file in C:\LicenseTracker2 folder to reference the second 
AR System server. 

 

10. Run FirstRegUserStats from C:\LicenseTracker2 folder to ensure the 
configuration is correct. 

---------------------------------------------------- 

11. Repeat steps 2 to 10 for each additional AR System server as needed. 
 
 

----- MULTIPLE SERVER INSTALLATION COMPLETED -----
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----- LICENSETRACKER CONFIGURATION ----- 

1. Initiate the population of default values for threshold identification and notification 
preferences.   

 Remedy User Tool > Object List > WAVE-Configuration > Search 

 It is recommended that you use these default values for 2-3 days before 
making changes to allow the system time to gather an accurate baseline. 

2. Allow the LicenseTracker to run for a few hours to gather preliminary statistics.  
The longer it runs, the more accurate the statistics will be for the license usage on 
your server. 

3. If you change the License Type of a user, you will not see that change reflected in 
the WAVE-UserStats form until either: 

 the user logs in again - OR -  

 the Scheduled Task that runs daily to capture statistics on registered users 

4. If you are storing the statistics on a different server than the one being  
monitored for license activity, modify the Open Window action of this active link to 
reference the Source server:       

 Remedy Administrator Tool > Active Links >  
WAVE-US-400-bShowUserTicket > If Action - (1) - then change the 
Target server name to the Source server name 

5. The WAVE-UserStats form is configured to automatically delete 6 month old 
records at the beginning of every month.  This can be altered/disabled via:   

 Remedy Administrator Tool > Forms > WAVE-UserStats >  
Form Properties > Archive 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 


